Error while linking to openzeppelin-eth


#1

Greetings,

I was following [https://blog.zeppelin.solutions/getting-started-with-openzeppelin-eth-a-new-stable-and-upgradeable-evm-package-576fb37297d0] I and got the following error:

zos%20link%20openzeppelin-eth

Does that mean that I first have to create the smart contract that creates my TFF_Token, which imports (links to) the openzeppelin-eth deployed packages, and then run this command?

The following are my config files:

json

Or is it that it is trying to link to existing (although not finished/usable) contracts currently placed in the /contracts/ directory as follows?:

contracts%20folder

Moreover, I have figured that the issue resides in the package.json file, specifically in the last keyword defined “TFF_Token”, so I removed the whole content as follows:

Then I ran [zos link openzeppelin-eth] and [npm install truffle] and I get similar errors as well as I keep getting the “repository” error; I obviously do not know how to fix it. :man_shrugging: Please help.

similar%20errors

Thanks in advance


How registering an EVM package in the ZeppelinOS ecosystem will look like
#2

Hey @jaureguino! I’m not sure what’s going on so I’m gonna tag @spalladino so he can help you :smile:


#3

Thanks @IvanTheGreatDev, I happen to be sending a message to @spalladino at this very moment. Cheers!


#4

Hey @jaureguino! The problem is not in zos but in npm itself. Your current package.json is not a valid JSON file, since you have a dangling comma in the keywords section. Try copy-pasting your package.json onto a linter such as https://jsonlint.com/ and fix it until it’s valid!


#5

:open_mouth::zipper_mouth_face: Thanks a lot!

success