Npm hanging on zos install

Hi all,

I have an issue installing zos into a new project. So now if I try and install zos using npm I see:

npm install zos
npm WARN deprecated lodash.isarray@4.0.0: This package is deprecated. Use Array.isArray.
npm WARN deprecated fs-promise@2.0.3: Use mz or fs-extra^3.0 with Promise Support
npm WARN deprecated tar.gz@1.0.7: :warning: WARNING :warning: tar.gz module has been deprecated and your application is vulnerable. Please use tar module instead: https://npmjs.com/tar
[ …] \ fetchMetadata: sill resolveWithNewModule http-https@1.0.0 checking installable status

And then the process will just hang at this point forever…

I am using the following versions:
node: v11.9.0
npm: v6.9.0

Any help appreciated!

Thanks
Rick

1 Like

I am not able to reproduce the issue unfortunately.

I can install ZeppelinOS in a new project with no issues
mkdir test
cd test
npm init -y
npm install zos

node: v11.9.0
npm: 6.9.0
zos: 2.3.1

Running on Ubuntu 18.04 on Windows Subsystem for Linux on Windows 10

What operating system are you using @roy.batty?

I am using Arch Linux… but you have reminded me that I did a system update a few days ago… could be related :thinking:

1 Like

OK, I managed to fix the issue… last week I was having some issues with internet access in a new location with wifi so I had to hack around a bit with my /etc/resolv.conf file to get general internet access again… turns out that while that fixed my general browsing it had a knock on effect on npm installs!

So in summary to fix the issue I replaced my /etc/resolve.conf file which had only the following line in it:

# Generated by NetworkManager
nameserver 192.168.0.1

with a previous version of the file I had saved which had the following contents:

nameserver 127.0.0.53
options edns0

And Walah! Everything works again, including the ‘npm install zos’…

Thanks to anyone who was looking into this for me!

Cheers
Rick

1 Like

Awesome, I was thinking I was going to have to try spinning up Arch Linux to attempt to reproduce.

1 Like

Haha, luckily you didn’t have to do that :slight_smile:

1 Like