Warnings and Errors while Installing ZOS


#1

OS: Windows 10 64x ; nose.js 10.15.1

After typing the following command [npm install --global zos] I get the warnings and errors shown in the image below. Please help.


#2

Hello @jaureguino! Thanks for using the forum :smiley:

Do you have python installed? If so what version? There seems to be an issue with python.


#3

Dear @IvanTheGreatDev,

Thanks a lot for your prompt response. I did not have python, so I installed it and then ran [ npm install --global zos ] as administrator and at the end I got the following warnings:

Warnings%20on%20Installing%20zos

Later I connected with my regular user [that is also administrator] and installed webpack. I was unable to install fsevents but successfully installed ganache-cli, fs_promise, babel-preset-env, tar but I kept getting the following fsevents warnings:

Q1. Is fsevents indispensable? It appears to be required for darwin [Max OS] …
Q2. Should I ignore fsevents warnings and assume that zos installed successfully?
Q3. I could not find nomnom in npmjs.com, I read it was no longer supported. Any thoughts on this?

Cheers!


#4

Hey bud, warnings shouldn’t be an issue when it comes to npm install, so no need to worry about those.
For 2, can you try typing npm install --no-optional for me? :smile:
Not sure about 3.


#5

Good morning @IvanTheGreatDev ,

Thanks for your support! Here is the return from your special request! :muscle:

npm%20install%20--no-optional

I guess I am ready to continue deployment :point_right: https://docs.zeppelinos.org/docs/deploying.html

Cheers!