Zos-lib solidity version 0.4.24

#1

Hi

Is there a reason why most contracts in zos-lib only support solidity version 0.4.24?

And also, thank you for all the great work with zeppelinos! :slight_smile:

1 Like
Creating upgradeable smart contracts using contract factory
#2

Where? All contracts I see are in Solidity 0.5: https://github.com/zeppelinos/zos/blob/feature/create2/packages/lib/contracts/application/App.sol


JK! Thanks for the question @imbenwolf: we have migrated the contracts recently as part of a new feature we are working on, and should all be in 0.5 for the 2.3 release (currently planned for the end of month).

3 Likes
#3

Hahah…
image

Very cool though. Excited for the next release!

2 Likes